Cordova Intercom build error after add cordova-plugin-firebase-analytics

When executing
cordova plugin add cordova-plugin-firebase-analytics
cordova prepare
cordova build
I get the following error:

> In project ‘app’ a resolved Google Play services library dependency depends on another at an exact version (e.g. "[17.1.
*** 2] ", but isn’t being resolved to that version. Behavior exhibited by the library will be unknown.***


*** Dependency failing: com.google.firebase: firebase-messaging: 17.6.0 -> com.google.firebase: firebase-iid @ [17.1.2], but fire***
*** base-iid version was 19.0.0.***


*** The following dependencies are project dependencies that are direct or have transitive dependencies that lead to the art***
*** ifact with the issue.***
*** - Project ‘app’ depends onto com.google.firebase: firebase-core@17.0.1***
*** - Project ‘app’ depends onto com.google.firebase: firebase-messaging@17.6.0***
*** - Project ‘app’ depends onto io.intercom.android:intercom-sdk-fcm@5.+***
*** - Project ‘app’ depends onto com.google.firebase: firebase-analytics@17.0.0***
*** - Project ‘app’ depends onto io.intercom.android:intercom-sdk-fcm@5.4.1***
*** - Project ‘app’ depends onto com.google.firebase: firebase-core@17.0.+***
*** - Project ‘app’ depends onto com.google.android.gms: play-services-measurement-api@17.0.0***
*** - Project ‘app’ depends onto com.google.firebase: firebase-iid@19.0.0***
*** - Project ‘app’ depends onto com.google.firebase: firebase-messaging@17.+***


*** For extended debugging info execute Gradle from the command line with ./gradlew --info: app: assembleDebug to see the dep***
*** endency paths to the artifact. This error message came from the google-services Gradle plugin, report issues at https: //***
*** github.com/google/play-services-plugins and disable by adding “googleServices {disableVersionCheck = false}” to your b***
*** uild.gradle file.***

**** Try:***
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

**** Get more help at https://help.gradle.org***

BUILD FAILED in 8s

I need help to realign the libraries.
Greetings.

Hey there :wave:

Our Cordova SDK is using com.google.firebase:firebase-messaging:17.+

It looks like you’re using com.google.firebase: firebase-messaging@17.6.0 which if I’m reading this right depends on com.google.firebase: firebase-iid@17.1.2

I believe the issue stems from com.google.firebase: firebase-iid@19.0.0 being used instead. Searching through the web I found other instances of this coming up not specifically related to Intercom:

I would try changing your dependencies up to see if that fixes this :+1: