Old Android build tools dependency on cordova plugin


#1

Hi

In this line the intercom cordova plugin is referencing a package version that is not available anymore on JCenter or Google Maven repositories. That cause an error when building the app:

Could not find any version that matches com.android.tools.build:gradle:2.3.+.

I’m using cordova-android v6.4.0 and can’t update right now because other plugins that I’m using.

If I change the referenced line to use ..gradle:3.0.0 it works ok. Can you consider update that dependency?


#2

Hi there :wave: Niall here, one of the Support Engineers at Intercom.

We’re tracking an issue for this internally, would it be ok to start a conversation with you in the messenger just so I can grab your details so I can alert you once a fix is released?

If that’s cool just start a conversation and ask for Niall and you should get assigned over :ok_hand:


#3

Hey Niall, We’re currently running into the same issue using cordova-android 7.1 and above. I can build the app using 7.0 but nothing higher than that. I would appreciate any notifications of updates as well!


#4

I finally got my project building. I cloned the intercom-cordova plugin, updated the gradle plugin to com.android.tools.build:gradle:3.2.1 and added the local version to my project. then in my project build.gradle I updated the repositories by adding google() and changed the maven url to "https://google.bintray.com/flexbox-layout". Let me know if there’s anything else I can help provide in order to resolve this ASAP!


#5

Hi Zach :wave: I can see you chatted to my colleague Sayam about this :+1:

I’ll leave the updates on this issue in his hands :smiley:


#6

Hi Everyone :wave: This is now fixed in our 6.2.0 release
https://github.com/intercom/intercom-cordova/releases/tag/6.2.0