Posts not showing in fullscreen mode


#1

When creating an auto-message as a Post, you have to tap on the message for it to expand in full screen mode. Is that by design or is there something we’re missing within the settings? We’re using the iOS SDK.


#2

Hi Allen :wave:

Danielle from the Intercom Support team here!

When testing this out myself, as long as you have the Post message set to “Display the Full Message” it should take over the full screen when it appears for users. Here’s an example of what that looked like for me:

When this message came through for you, did you you have any other messages that were unread or arriving at the same time? If there are any other messages that are popping up for the user at the same time we will instead stack these messages rather than opening the Post in full to take up the full screen. If you click into the Post message, then it should open up to the full screen view. :+1:

If this wasn’t the case for you, then I’d encourage that you reach out to us through the messenger at intercom.com so we can dig into this specific instance a bit deeper for you!


#3

Do you mean “Show the full message” under “Sent as”? If so, that’s what I used and is why the message gets cut off ironically.


#4

Yep, the Sent as section is what I’m referring to!

So you currently have this message set to send as a Post message type with the Sent as set to Show the full message and when arriving to your iOS application without being accompanied by any other messages it initially shows as a snippet that needs to be clicked into?

If that is the case, would you mind writing into us through the messenger so we can see what might be going on here? If the Post message is arriving on it’s own, it should be showing in full so if that isn’t what you’re seeing it sounds like it isn’t expected behavior.