The app is closed in iOS 13.1

Hey
I’m using cordova-plugin-intercom and when I try to send an image in the intercom, the app is closed and this is the error log:

2019-10-24 13:53:41.376355-0400 Pluto[20966:3148536] *** Terminating app due to uncaught exception ‘NSInvalidArgumentException’, reason: ‘*** -[__NSPlaceholderDictionary initWithObjects:forKeys:count:]: attempt to insert nil object from objects[0]’
*** First throw call stack:
(
0 CoreFoundation 0x00007fff23c0b02e __exceptionPreprocess + 350
1 libobjc.A.dylib 0x00007fff50b00b20 objc_exception_throw + 48
2 CoreFoundation 0x00007fff23c9da71 _CFThrowFormattedException + 194
3 CoreFoundation 0x00007fff23ca8496 -[__NSPlaceholderDictionary initWithObjects:forKeys:count:].cold.4 + 38
4 CoreFoundation 0x00007fff23c68d57 -[__NSPlaceholderDictionary initWithObjects:forKeys:count:] + 247
5 CoreFoundation 0x00007fff23c06edb +[NSDictionary dictionaryWithObjects:forKeys:count:] + 59
6 Pluto 0x000000010f231e79 +[IntercomSDK_ITBBlockUtils imageBlockForUpload:appearance:] + 298
7 Pluto 0x000000010f3381e3 +[ICMConversationPart sendingPartWithBlocks:upload:] + 605
8 Pluto 0x000000010f31c3fc -[ICMConversationContentViewController startNewConversationWithBlocks:upload:] + 283
9 Pluto 0x000000010f319bf5 -[ICMConversationContentViewController sendUpload:] + 177
10 Pluto 0x000000010f2fa8a4 -[ICMConversationViewController sendMessage:upload:] + 179
11 Pluto 0x000000010f2fa51e __74-[ICMConversationViewController inputAccessoryView:input:performedAction:]_block_invoke + 96
12 libdispatch.dylib 0x000000010fc7ddd4 _dispatch_call_block_and_release + 12
13 libdispatch.dylib 0x000000010fc7ed48 _dispatch_client_callout + 8
14 libdispatch.dylib 0x000000010fc8cde6 _dispatch_main_queue_callback_4CF + 1500
15 CoreFoundation 0x00007fff23b6ddf9 CFRUNLOOP_IS_SERVICING_THE_MAIN_DISPATCH_QUEUE + 9
16 CoreFoundation 0x00007fff23b68a59 __CFRunLoopRun + 2329
17 CoreFoundation 0x00007fff23b67e16 CFRunLoopRunSpecific + 438
18 GraphicsServices 0x00007fff383d1bb0 GSEventRunModal + 65
19 UIKitCore 0x00007fff477bcef8 UIApplicationMain + 1621
20 Pluto 0x000000010f062f31 main + 65
21 libdyld.dylib 0x00007fff51986c39 start + 1
)
libc++abi.dylib: terminating with uncaught exception of type NSException
(lldb)

Somebody know why?

Hey Richi!

If you don’t mind could you write into the Messenger on your Intercom workspace so we can take a deeper look into your setup? One of our engineers will reach out once you send us a message there :+1:

This issue here is that Cordova is using the a version of the iOS SDK that does not work with iOS 13.
We are working on updating Cordova to be compatible with iOS SDK 5.5.0 which has support for iOS 13.
Brian

Hey, thanks for the new version of Intercom.
I have a situation, I removed the old plugin and Installed the version 8.0.0
When this is installing, it gives me this error and the process is over, look:

Installing “cordova-plugin-intercom” for ios
Updating CocoaPods specs repo
“framework” tag with type “podspec” is deprecated and will be removed. Please use the “podspec” tag.
Running command: pod install --verbose
Failed to install ‘cordova-plugin-intercom’: Error: pod: Command failed with exit code 1
at ChildProcess.whenDone (/Users/rikycg/Development/pluto/node_modules/cordova-common/src/superspawn.js:135:23)
at emitTwo (events.js:106:13)
at ChildProcess.emit (events.js:191:7)
at maybeClose (internal/child_process.js:920:16)
at Socket. (internal/child_process.js:351:11)
at emitOne (events.js:96:13)
at Socket.emit (events.js:188:7)
at Pipe._handle.close [as _onclose] (net.js:497:12)
pod: Command failed with exit code 1

Do you know why?
Thanks

This is an issue with Cordova rather than Intercom so you might find a solution on Cordova forums.
However, I’d make sure you’re using the most up to date version of Cordova-iOS and the core Cordova plugins.

Brian

Hey Brian, I don’t think the problem is with Cordova, because this error is only with Intercom, we use other plugin with Cocoapods and they work good. In fact, when I try to install using pod install --verbose it gives me this error:

Resolving dependencies of Podfile
[!] CocoaPods could not find compatible versions for pod “Intercom”:
In Podfile:
Intercom (~> 6.0.0)

Specs satisfying the Intercom (~> 6.0.0) dependency were found, but they required a higher minimum deployment target.

Did you see this error before?
Thanks

Brian, forget this, you right. I forgot to change the deployment-target value in the config.xml, I changed that and it works good.
Thanks for your support.
Regards

1 Like