Answered

401 error setting up authentication token

  • 9 January 2024
  • 1 reply
  • 78 views

I’m new to Intercom and I’m setting up my first Custom Actions. The app that I use the most is called Simplero so it is my top priority for getting set up.

It uses Basic authentication (ref https://github.com/Simplero/Simplero-API?tab=readme-ov-file#authentication) and I’ve set up an authentication text token (ref https://www.intercom.com/help/en/articles/6615543-setting-up-custom-actions-authentication#h_7c58d5179f) in Intercom: 

In the Token value box, I pasted my API key. The API key that I have works. I’ve tested it in other apps (i.e. Pipedream) and it works just fine. I’ve also tried generating new API keys and I’ve tried 3 different ones. All of them return the following error: 

401 Unauthorized

{"error":"Bad API key"}

The setup appears so simple, I can’t imagine what I might be doing wrong. So I tried setting up another Authentication Token for a different app I also use, and that one works fine, although it’s a Bearer token not Basic. So I’m not completely a newbie, but I’m by no means a coding wizard.

I’m wondering if the issue is punctuation/spacing/something like that? One of the problems is I can’t see what query is getting sent or have a detailed log, so I’m not sure how to troubleshoot this. I’ve been in contact with tech support at both Simplero and Intercom and everyone tells me that “it should work.”

If anyone can even help me with “have you tried X” or “something similar happened with this other app” I’d be most grateful!

icon

Best answer by Ebenezer.Laleye 17 January 2024, 16:26

View original

1 reply

Userlevel 1
Badge +2

Hi Ali! Ebenezer here from Engineering Support👋.

I actually saw the conversation you had with one of my colleagues, and they have raised a bug for this issue.

Our R&D team will add this to their backlog to get fixed and get back to the IC you were speaking with when they have an update. They have more intricate tools to find out what's going on.

Reply