Answered

How can we disable the "send us a message" in the Help Centre articles?

  • 23 November 2023
  • 6 replies
  • 159 views

Hello! 😊

We noticed that upon pressing a Sad emoji on a Help Center article, we are asking people to Send us a message. This seems to only available on iOS, and not on Android. Regardless, we really need it disabled.

We have already disabled the “automatically start a message”, but we also need the manual way out :) 

How can we do this? Thank you! 

icon

Best answer by Jacob Cox 2 December 2023, 23:40

View original

6 replies

Userlevel 1
Badge +3

Hi @Ruxandra -- I’m Cam from the Intercom Support team!

Could you check and confirm what Intercom iOS SDK version is being used in your iOS App?

There was a bug identified previously with behaviours similar to what you’ve described - a fix for this was released from iOS SDK v15.1.4 onwards, so if you’re running anything prior to this I’d highly recommend updating the SDK version being used (ideally to our most recently released iOS SDK v.16.3.1)

Hi @Cam G. we use the react native SDK, can you confirm in which version this was fixed?

Userlevel 4
Badge +5

Hi @Nigel-Paxton !

I took a look at your team’s iOS app and it looks like it pre-dates the fix that my teammate, Cam, mentioned. I would recommend updating your react-native SDK to the most recent version (currently that’s version 6.2.0).

Before you do that, you’ll also want to check and make sure that you have your Messenger Settings set up so that it doesn’t open a conversation when a customer provides an unhappy CSAT rating. You’ll want to make sure the option is toggled off  here! 👇🏼

 

 

hey @Jacob Cox unfortunately this issue still persists after we’ve updated to 6.3.0 and the toggle is off

cc @hvalec ziga 

Badge

Hi. i noticed the same issue.

I tested both “Let users start a conversation” on and off. And i think i found an issue.

When i don’t have any conversations and the above option is ON I get this screen. Which is correct. Top right you have an icon to start conversations and in the middle you also have a button to start new conversations.

When i switch this to OFF i get this screen which is NOT correct. As you can see at the top right the icon is gone. Which is correct as a have disabled starting new conversations but the button is still available in the middle of the screen. Seems like the button in the middle doesn’t follow the setting but the button in top right does


EDIT: This was tested on react native v6.3.0

Userlevel 4
Badge +5

Hey there @Nigel-Paxton and @hvalec ziga!

Thanks for updating the SDK and for sending over those screenshots. I’m going to send you both over to our Support team to chat through this issue. That way they can dig into your specific details. I’m thinking that a bug report will need to be open with our team for this. Our support team will reach out to you via the Email address that you currently have on file with us!

 

Reply