Answered

Let users start a conversation not working correctly for new customers

  • 8 January 2024
  • 4 replies
  • 273 views

Badge

Hi. I have a problem with the “Let users start a conversation” setting not working for customers with zero conversations.

This was tested on react native v6.3.0 and i tried both “Let users start a conversation” on and off. And i think i found an issue.

When i don’t have any conversations and the above option is ON I get this screen. Which is correct. Top right you have an icon to start conversations and in the middle you also have a button to start new conversations.

When i switch this to OFF i get this screen which is NOT correct. As you can see at the top right the icon is gone. Which is correct as a have disabled starting new conversations but the button is still available in the middle of the screen. Seems like the button in the middle doesn’t follow the setting but the button in top right does

 

icon

Best answer by bernice 11 January 2024, 12:19

View original

4 replies

Userlevel 4
Badge +4

Hey there @hvalec ziga! Bernice from Support Engineering at Intercom here 🔧

 

Thanks for confirming you’re using the latest version of the React Native wrapper.

 

Can you tell me where you’re seeing this case of the Messenger/where you’ve accessed it from? I.e. your Help Center, your app landing page.

Badge

this is after using the presentSpace from react native intercom package. It opens the above modal right away. There are no previous screens

Userlevel 4
Badge +4

Thanks for confirming this, @hvalec ziga - I’m going to pass this over to the team to take further action on this issue for you. 

Badge

thank you

Reply