Answered

How to hide "intercom-notifications-frame"

  • 25 September 2023
  • 2 replies
  • 118 views

Hi,
I have set hide_default_launcher: true when booting Intercom

window.Intercom?.("boot", {

   api_base: "api_base",

   app_id: “appId”,

   user_id: “userId”,

   email,

   hide_default_launcher: hideDefaultLauncher,
});
But the intercom-notifications-frame"is still shown, how to force hide it?

(The issue relates to my checklist or tasks of Intercom)

Thanks

icon

Best answer by Eden 28 September 2023, 20:40

View original

2 replies

Userlevel 3
Badge

Hi @App Intercom 👋 Eden from the support engineer team here.

 

At the moment, there isn’t a way to hide “ intercom-notifications-frame”-- there isn’t a way to force notifications to not show in the Messenger if they are targeted to specific users, even with the Messenger hidden. If you are looking to prevent users from receiving any messages or notifications on that page, you will want to make sure you are setting a URL rule for  outbound messages like that Checklist that specifies that it should not appear on that URL: 

 

 

 

 

 

 

 

 

 

 

 

 

 

Let me know if you have questions on that.

.

Reply