Intercom Latest version 15.1.6 not compatible with compose version 1.5.0

  • 14 August 2023
  • 2 replies
  • 112 views

Hello Intercom Community , 

I am getting crash when i navigate to Intercom Messenger (version of 15.1.0 to 15.1.6 )

Ex : Intercom.client().present(space = IntercomSpace.Messages)

 

i am using kotlin version 1.9.0 and compose version 1.5.0

but in version of intercom  15.0.0  everything working good,

So i raise this issue , Please give me proper solution 

cameron.gumley 5 months ago

Quick update and some good news for you @IxfianIshant!

Our new Android SDK version 15.2.1 that supports Jetpack Compose 1.5 is released now. 🎉 After updating your package you shouldn’t run into anymore issues but let us know if you are seeing otherwise!

View original

2 replies

Userlevel 2
Badge +3

Hi @IxfianIshant ! I’m Cam, one of the Intercom Support Engineers. 

Just wanted to let you know that we’ve got an Issue Report open with our Product Engineering team on this, so it is certainly something the team has been/is working to address. The teams most recent update indicates this may be fixed in an upcoming Android SDK update - I’ve reached out to confirm this with them and will let you know as soon as I hear back 👍

Userlevel 2
Badge +3

Quick update and some good news for you @IxfianIshant!

Our new Android SDK version 15.2.1 that supports Jetpack Compose 1.5 is released now. 🎉 After updating your package you shouldn’t run into anymore issues but let us know if you are seeing otherwise!

Reply