Answered

Why is my date attribute showing up in a different language?


Hi, our product is based in Portugal but we work with different languages. I'm working on a Series for english language customers and would like to include the date their trial expires. I'm using an attribute which sends the date in numerical values, but for some reason it shows up on our emails as text, and in Portuguese for some reason.

How can I change this?

 

Ideally I would like for the date to show up at DD/MM/YYYY, but if that's not possible at least in english, so the customers don't get confused.

 

Thanks!date

icon

Best answer by Roy 6 April 2021, 15:08

View original

11 replies

Badge

Hello @user939​ 👋, Happy Easter 🐰

 

You created the plan_expire_at attribute as a date, like this one:

Plan_expire_atCurrently, it's not possible to select date format or send dates in different languages. However, you can create a new similar attribute (Plan_expire_txt) in Text format, send Intercom date and show them like DD/MM/YYYY.

 

Plan_txtI totally understood it's not the best way to deal with this problem. That's why I'm tagging @Product Wishlist​ group, hope someone from the Intercom product team catches this feedback about date translation/format.

 

Please let me know if you need any further assistance on this 😊

Userlevel 4
Badge +5

All the temporal (_at) attributes should be defined as Date timestamp type and the value should be in UNIX timestamp format. https://en.wikipedia.org/wiki/Unix_time

 

I.e. "created_at": 1389913941

 

I assume you do it like that.

 

And then if you use that attribute in the messages, UNIX timestamp will be encoded as "mmm dd yyyy" where mmm is the first three letters of the month's name.

 

I assume the content goes out as already encoded on sending not on receiving end (in which case it would depend on the email client if it is an email being sent).

 

Assuming it is the first scenario, the language of that month part might depend on the language of your Intercom (that's my logical assumption, I do not know for sure). Do you have multiple languages set for Intercom? https://www.intercom.com/help/en/articles/180-localize-intercom-to-work-with-multiple-languages

 

If you do have more, I wonder what would an email message with the encoded date attribute look like if you have only English as a defined language?

 

 

Badge

@user382​ ,

 

Q - Assuming it is the first scenario, the language of that month part might depend on the language of your Intercom

A - Afraid not, If you run Intercom on multiple languages, date still displaying in the Default language.

 

That's why the Intercom Product team should work on date format customization and localization.

Userlevel 4
Badge +5

What would be the Default language then?

Badge

@user382​ , In @user939​ case, default language will be Portuguese, cause they mostly working in Portugal market.

 

If they set up the default language in English, the data format will be displayed in English only. Also, they need to manually change the pages, add the Language_overide tag (Cause Intercom language detection is based on user device settings).

Hey @roy s11​ 

The screenshot I shared on my original post was from a preview e-mail of a user which has the language_overide tag.

This is from their user details page:

 

Screenshot 2021-04-06 at 12.50.19 

So why is the date in the e-mail for this user showing up in Portuguese?

Thanks for your help!

Badge

Hi @user939​ ,

 

Q - So why is the date in the e-mail for this user showing up in Portuguese?

A - Cause Intercom does not use this parameter (Language override or Browser language) to show date formats in this language.

Intercom uses only the default language when it comes to date formats.

 

What you are asking is more likely a feature request, Intercom should fix this or develop some solution.

 

BTW - Some community members already asked about this problem.

 

In the meantime, until some solution will be made by Intercom you can:

 

- Create a new custom attribute "Plan_Expire_TXT" (Example);

- Use TXT Format;

- Send Intercom dates via this attribute in the following format (06.04.2021 - DD/MM/Year);

- Then display this attribute during e-mail/conversation sending.

 

Keep in mind that you shouldn't delete/remove the old attribute (plan_expire_at).

 

You can also change the default language to English, but then dates will be shown only in English.

Also, this can cause some problems for already installed messenger.

 

Badge

@user939​ , If you change your default language to English then dates will be sent only in English.

However, before you change it check every page/app where the messenger was in Portuguese to add Language_override tag.

Thanks @roy s11​, I understand the issue now!

 

Userlevel 1

Hey @roy s11​ and @user382​, thanks so much for both jumping in here to provide some clarity to @user939​.

 

I'm going to tag in our @Product Wishlist​ group here so that I record this feedback. As mentioned, Intercom will use the same language for your date attributes (and the unsubscribe link and page) as your default Messenger language, and won't revert to any secondary languages or respect any language override.

 

I can totally see how this causes issues for customers dealing with customers from different countries, so I'm happy to add this product feedback to my monthly report.

Userlevel 4
Badge +5

That's what I was suggesting in my answer - that the language of the Month depends on the language of the Intercom (or what you defined "Default language").

Reply