Answered

Messenger not appearing on website. Error: The App ID in your code snippet has not been set.

  • 10 May 2024
  • 2 replies
  • 640 views

Help please. I tried all the troubleshooting steps to make the messenger appear on our website’s contact page. But I always get the error: “The App ID in your code snippet has not been set. Launcher is disabled in settings or current page does not match display conditions.”

It’s weird because the App ID is already in the script. Any way how to solve this?

This is for website visitors without logins. 

I copied the code snippet for “website visitors without logins” from this page: https://app.intercom.com/a/apps/pkf1yel7/settings/installation-new over to the Webflow page before the </body> tag. 

Now I don’t know what else to do.

icon

Best answer by Darren G 10 May 2024, 09:32

View original

2 replies

Userlevel 1
Badge

Hi,

I took a quick look at your website source code and it looks like you’re just missing a closing tag on the <script> tag prior to your Intercom settings, so they are not being picked up.

In the line:

<script src="https://cdn.jsdelivr.net/gh/videsigns/webflow-tools@latest/cms-search.js" < script>

You need to change the last < script> tag to </script>

Thank you so much for this! Kinda funny mistake, but that solved it finally 🤣 Cheers!

Reply