Answered

failed to build android project

  • 15 September 2023
  • 1 reply
  • 199 views

so after adding the library I get this error while building project, how to fix that?
i don’t have exoplayer on my project, i even tried to add that, but nothing really changed
 

FAILURE: Build completed with 8 failures.

1: Task failed with an exception.
-----------
* What went wrong:
Execution failed for task ':app:mapProductionDebugSourceSetPaths'.
> Could not resolve all files for configuration ':app:productionDebugRuntimeClasspath'.
   > Failed to transform exoplayer-2.19.0.aar (com.google.android.exoplayer:exoplayer:2.19.0) to match attributes {artifactType=android-res, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-2.19.0.aar (com.google.android.exoplayer:exoplayer:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer/2.19.0/exoplayer-2.19.0.aar
   > Failed to transform exoplayer-rtsp-2.19.0.aar (com.google.android.exoplayer:exoplayer-rtsp:2.19.0) to match attributes {artifactType=android-res, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-rtsp-2.19.0.aar (com.google.android.exoplayer:exoplayer-rtsp:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer-rtsp/2.19.0/exoplayer-rtsp-2.19.0.aar
   > Failed to transform exoplayer-database-2.19.0.aar (com.google.android.exoplayer:exoplayer-database:2.19.0) to match attributes {artifactType=android-res, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-database-2.19.0.aar (com.google.android.exoplayer:exoplayer-database:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer-database/2.19.0/exoplayer-database-2.19.0.aar
   > Failed to transform exoplayer-extractor-2.19.0.aar (com.google.android.exoplayer:exoplayer-extractor:2.19.0) to match attributes {artifactType=android-res, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-extractor-2.19.0.aar (com.google.android.exoplayer:exoplayer-extractor:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer-extractor/2.19.0/exoplayer-extractor-2.19.0.aar
   > Failed to transform sqlite-2.3.0.aar (androidx.sqlite:sqlite:2.3.0) to match attributes {artifactType=android-res, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find sqlite-2.3.0.aar (androidx.sqlite:sqlite:2.3.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/androidx/sqlite/sqlite/2.3.0/sqlite-2.3.0.aar

* Try:
> Run with --stacktrace option to get the stack trace.
> Run with --info or --debug option to get more log output.
> Run with --scan to get full insights.
> Get more help at https://help.gradle.org.
==============================================================================

2: Task failed with an exception.
-----------
* What went wrong:
Execution failed for task ':app:mergeProductionDebugResources'.
> Could not resolve all files for configuration ':app:productionDebugRuntimeClasspath'.
   > Failed to transform exoplayer-2.19.0.aar (com.google.android.exoplayer:exoplayer:2.19.0) to match attributes {artifactType=android-res, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-2.19.0.aar (com.google.android.exoplayer:exoplayer:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer/2.19.0/exoplayer-2.19.0.aar
   > Failed to transform exoplayer-rtsp-2.19.0.aar (com.google.android.exoplayer:exoplayer-rtsp:2.19.0) to match attributes {artifactType=android-res, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-rtsp-2.19.0.aar (com.google.android.exoplayer:exoplayer-rtsp:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer-rtsp/2.19.0/exoplayer-rtsp-2.19.0.aar
   > Failed to transform exoplayer-database-2.19.0.aar (com.google.android.exoplayer:exoplayer-database:2.19.0) to match attributes {artifactType=android-res, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-database-2.19.0.aar (com.google.android.exoplayer:exoplayer-database:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer-database/2.19.0/exoplayer-database-2.19.0.aar
   > Failed to transform exoplayer-extractor-2.19.0.aar (com.google.android.exoplayer:exoplayer-extractor:2.19.0) to match attributes {artifactType=android-res, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-extractor-2.19.0.aar (com.google.android.exoplayer:exoplayer-extractor:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer-extractor/2.19.0/exoplayer-extractor-2.19.0.aar
   > Failed to transform sqlite-2.3.0.aar (androidx.sqlite:sqlite:2.3.0) to match attributes {artifactType=android-res, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find sqlite-2.3.0.aar (androidx.sqlite:sqlite:2.3.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/androidx/sqlite/sqlite/2.3.0/sqlite-2.3.0.aar

* Try:
> Run with --stacktrace option to get the stack trace.
> Run with --info or --debug option to get more log output.
> Run with --scan to get full insights.
> Get more help at https://help.gradle.org.
==============================================================================

3: Task failed with an exception.
-----------
* What went wrong:
Execution failed for task ':app:checkProductionDebugAarMetadata'.
> Could not resolve all files for configuration ':app:productionDebugRuntimeClasspath'.
   > Failed to transform exoplayer-2.19.0.aar (com.google.android.exoplayer:exoplayer:2.19.0) to match attributes {artifactType=android-aar-metadata, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-2.19.0.aar (com.google.android.exoplayer:exoplayer:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer/2.19.0/exoplayer-2.19.0.aar
   > Failed to transform exoplayer-rtsp-2.19.0.aar (com.google.android.exoplayer:exoplayer-rtsp:2.19.0) to match attributes {artifactType=android-aar-metadata, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-rtsp-2.19.0.aar (com.google.android.exoplayer:exoplayer-rtsp:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer-rtsp/2.19.0/exoplayer-rtsp-2.19.0.aar
   > Failed to transform exoplayer-database-2.19.0.aar (com.google.android.exoplayer:exoplayer-database:2.19.0) to match attributes {artifactType=android-aar-metadata, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-database-2.19.0.aar (com.google.android.exoplayer:exoplayer-database:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer-database/2.19.0/exoplayer-database-2.19.0.aar
   > Failed to transform exoplayer-extractor-2.19.0.aar (com.google.android.exoplayer:exoplayer-extractor:2.19.0) to match attributes {artifactType=android-aar-metadata, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-extractor-2.19.0.aar (com.google.android.exoplayer:exoplayer-extractor:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer-extractor/2.19.0/exoplayer-extractor-2.19.0.aar
   > Failed to transform sqlite-2.3.0.aar (androidx.sqlite:sqlite:2.3.0) to match attributes {artifactType=android-aar-metadata, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find sqlite-2.3.0.aar (androidx.sqlite:sqlite:2.3.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/androidx/sqlite/sqlite/2.3.0/sqlite-2.3.0.aar

* Try:
> Run with --stacktrace option to get the stack trace.
> Run with --info or --debug option to get more log output.
> Run with --scan to get full insights.
> Get more help at https://help.gradle.org.
==============================================================================

4: Task failed with an exception.
-----------
* What went wrong:
Execution failed for task ':app:processProductionDebugMainManifest'.
> Could not resolve all files for configuration ':app:productionDebugRuntimeClasspath'.
   > Failed to transform exoplayer-2.19.0.aar (com.google.android.exoplayer:exoplayer:2.19.0) to match attributes {artifactType=android-manifest, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-2.19.0.aar (com.google.android.exoplayer:exoplayer:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer/2.19.0/exoplayer-2.19.0.aar
   > Failed to transform exoplayer-rtsp-2.19.0.aar (com.google.android.exoplayer:exoplayer-rtsp:2.19.0) to match attributes {artifactType=android-manifest, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-rtsp-2.19.0.aar (com.google.android.exoplayer:exoplayer-rtsp:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer-rtsp/2.19.0/exoplayer-rtsp-2.19.0.aar
   > Failed to transform exoplayer-database-2.19.0.aar (com.google.android.exoplayer:exoplayer-database:2.19.0) to match attributes {artifactType=android-manifest, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-database-2.19.0.aar (com.google.android.exoplayer:exoplayer-database:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer-database/2.19.0/exoplayer-database-2.19.0.aar
   > Failed to transform exoplayer-extractor-2.19.0.aar (com.google.android.exoplayer:exoplayer-extractor:2.19.0) to match attributes {artifactType=android-manifest, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-extractor-2.19.0.aar (com.google.android.exoplayer:exoplayer-extractor:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer-extractor/2.19.0/exoplayer-extractor-2.19.0.aar
   > Failed to transform sqlite-2.3.0.aar (androidx.sqlite:sqlite:2.3.0) to match attributes {artifactType=android-manifest, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find sqlite-2.3.0.aar (androidx.sqlite:sqlite:2.3.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/androidx/sqlite/sqlite/2.3.0/sqlite-2.3.0.aar

* Try:
> Run with --stacktrace option to get the stack trace.
> Run with --info or --debug option to get more log output.
> Run with --scan to get full insights.
> Get more help at https://help.gradle.org.
==============================================================================

5: Task failed with an exception.
-----------
* What went wrong:
Execution failed for task ':app:mergeProductionDebugAssets'.
> Could not resolve all files for configuration ':app:productionDebugRuntimeClasspath'.
   > Failed to transform exoplayer-2.19.0.aar (com.google.android.exoplayer:exoplayer:2.19.0) to match attributes {artifactType=android-assets, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-2.19.0.aar (com.google.android.exoplayer:exoplayer:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer/2.19.0/exoplayer-2.19.0.aar
   > Failed to transform exoplayer-rtsp-2.19.0.aar (com.google.android.exoplayer:exoplayer-rtsp:2.19.0) to match attributes {artifactType=android-assets, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-rtsp-2.19.0.aar (com.google.android.exoplayer:exoplayer-rtsp:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer-rtsp/2.19.0/exoplayer-rtsp-2.19.0.aar
   > Failed to transform exoplayer-database-2.19.0.aar (com.google.android.exoplayer:exoplayer-database:2.19.0) to match attributes {artifactType=android-assets, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-database-2.19.0.aar (com.google.android.exoplayer:exoplayer-database:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer-database/2.19.0/exoplayer-database-2.19.0.aar
   > Failed to transform exoplayer-extractor-2.19.0.aar (com.google.android.exoplayer:exoplayer-extractor:2.19.0) to match attributes {artifactType=android-assets, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-extractor-2.19.0.aar (com.google.android.exoplayer:exoplayer-extractor:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer-extractor/2.19.0/exoplayer-extractor-2.19.0.aar
   > Failed to transform sqlite-2.3.0.aar (androidx.sqlite:sqlite:2.3.0) to match attributes {artifactType=android-assets, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find sqlite-2.3.0.aar (androidx.sqlite:sqlite:2.3.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/androidx/sqlite/sqlite/2.3.0/sqlite-2.3.0.aar

* Try:
> Run with --stacktrace option to get the stack trace.
> Run with --info or --debug option to get more log output.
> Run with --scan to get full insights.
> Get more help at https://help.gradle.org.
==============================================================================

6: Task failed with an exception.
-----------
* What went wrong:
Execution failed for task ':app:checkProductionDebugDuplicateClasses'.
> Could not resolve all files for configuration ':app:productionDebugRuntimeClasspath'.
   > Failed to transform exoplayer-2.19.0.aar (com.google.android.exoplayer:exoplayer:2.19.0) to match attributes {artifactType=enumerated-runtime-classes, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-2.19.0.aar (com.google.android.exoplayer:exoplayer:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer/2.19.0/exoplayer-2.19.0.aar
   > Failed to transform exoplayer-rtsp-2.19.0.aar (com.google.android.exoplayer:exoplayer-rtsp:2.19.0) to match attributes {artifactType=enumerated-runtime-classes, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-rtsp-2.19.0.aar (com.google.android.exoplayer:exoplayer-rtsp:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer-rtsp/2.19.0/exoplayer-rtsp-2.19.0.aar
   > Failed to transform exoplayer-database-2.19.0.aar (com.google.android.exoplayer:exoplayer-database:2.19.0) to match attributes {artifactType=enumerated-runtime-classes, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-database-2.19.0.aar (com.google.android.exoplayer:exoplayer-database:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer-database/2.19.0/exoplayer-database-2.19.0.aar
   > Failed to transform exoplayer-extractor-2.19.0.aar (com.google.android.exoplayer:exoplayer-extractor:2.19.0) to match attributes {artifactType=enumerated-runtime-classes, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-extractor-2.19.0.aar (com.google.android.exoplayer:exoplayer-extractor:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer-extractor/2.19.0/exoplayer-extractor-2.19.0.aar
   > Failed to transform sqlite-2.3.0.aar (androidx.sqlite:sqlite:2.3.0) to match attributes {artifactType=enumerated-runtime-classes, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find sqlite-2.3.0.aar (androidx.sqlite:sqlite:2.3.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/androidx/sqlite/sqlite/2.3.0/sqlite-2.3.0.aar

* Try:
> Run with --stacktrace option to get the stack trace.
> Run with --info or --debug option to get more log output.
> Run with --scan to get full insights.
> Get more help at https://help.gradle.org.
==============================================================================

7: Task failed with an exception.
-----------
* What went wrong:
Execution failed for task ':app:mergeProductionDebugNativeLibs'.
> Could not resolve all files for configuration ':app:productionDebugRuntimeClasspath'.
   > Failed to transform exoplayer-2.19.0.aar (com.google.android.exoplayer:exoplayer:2.19.0) to match attributes {artifactType=android-jni, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-2.19.0.aar (com.google.android.exoplayer:exoplayer:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer/2.19.0/exoplayer-2.19.0.aar
   > Failed to transform exoplayer-rtsp-2.19.0.aar (com.google.android.exoplayer:exoplayer-rtsp:2.19.0) to match attributes {artifactType=android-jni, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-rtsp-2.19.0.aar (com.google.android.exoplayer:exoplayer-rtsp:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer-rtsp/2.19.0/exoplayer-rtsp-2.19.0.aar
   > Failed to transform exoplayer-database-2.19.0.aar (com.google.android.exoplayer:exoplayer-database:2.19.0) to match attributes {artifactType=android-jni, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-database-2.19.0.aar (com.google.android.exoplayer:exoplayer-database:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer-database/2.19.0/exoplayer-database-2.19.0.aar
   > Failed to transform exoplayer-extractor-2.19.0.aar (com.google.android.exoplayer:exoplayer-extractor:2.19.0) to match attributes {artifactType=android-jni, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-extractor-2.19.0.aar (com.google.android.exoplayer:exoplayer-extractor:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer-extractor/2.19.0/exoplayer-extractor-2.19.0.aar
   > Failed to transform sqlite-2.3.0.aar (androidx.sqlite:sqlite:2.3.0) to match attributes {artifactType=android-jni, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find sqlite-2.3.0.aar (androidx.sqlite:sqlite:2.3.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/androidx/sqlite/sqlite/2.3.0/sqlite-2.3.0.aar

* Try:
> Run with --stacktrace option to get the stack trace.
> Run with --info or --debug option to get more log output.
> Run with --scan to get full insights.
> Get more help at https://help.gradle.org.
==============================================================================

8: Task failed with an exception.
-----------
* What went wrong:
Execution failed for task ':calling:ui-calling:transformDebugClassesWithAsm'.
> Could not resolve all artifacts for configuration ':calling:ui-calling:debugRuntimeClasspath'.
   > Failed to transform exoplayer-2.19.0.aar (com.google.android.exoplayer:exoplayer:2.19.0) to match attributes {artifactType=android-classes-jar, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-2.19.0.aar (com.google.android.exoplayer:exoplayer:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer/2.19.0/exoplayer-2.19.0.aar
   > Failed to transform exoplayer-rtsp-2.19.0.aar (com.google.android.exoplayer:exoplayer-rtsp:2.19.0) to match attributes {artifactType=android-classes-jar, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-rtsp-2.19.0.aar (com.google.android.exoplayer:exoplayer-rtsp:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer-rtsp/2.19.0/exoplayer-rtsp-2.19.0.aar
   > Failed to transform exoplayer-database-2.19.0.aar (com.google.android.exoplayer:exoplayer-database:2.19.0) to match attributes {artifactType=android-classes-jar, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-database-2.19.0.aar (com.google.android.exoplayer:exoplayer-database:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer-database/2.19.0/exoplayer-database-2.19.0.aar
   > Failed to transform exoplayer-extractor-2.19.0.aar (com.google.android.exoplayer:exoplayer-extractor:2.19.0) to match attributes {artifactType=android-classes-jar, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find exoplayer-extractor-2.19.0.aar (com.google.android.exoplayer:exoplayer-extractor:2.19.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/com/google/android/exoplayer/exoplayer-extractor/2.19.0/exoplayer-extractor-2.19.0.aar
   > Failed to transform sqlite-2.3.0.aar (androidx.sqlite:sqlite:2.3.0) to match attributes {artifactType=android-classes-jar, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-runtime}.
      > Could not find sqlite-2.3.0.aar (androidx.sqlite:sqlite:2.3.0).
        Searched in the following locations:
            https://dl.google.com/dl/android/maven2/androidx/sqlite/sqlite/2.3.0/sqlite-2.3.0.aar

* Try:
> Run with --stacktrace option to get the stack trace.
> Run with --info or --debug option to get more log output.
> Run with --scan to get full insights.
> Get more help at https://help.gradle.org.
==============================================================================

BUILD FAILED in 5m 8s

icon

Best answer by Eden 20 September 2023, 21:08

View original

1 reply

Userlevel 3
Badge

Hey @rq_mehdi 👋 Eden from the support engineer team here.

 

Taking a look at the crash logs you’ve included, it doesn’t looks like Intercom is referenced at all. This indicates that the crash occurring when building your app isn’t an issue occurring with the Intercom SDK! If you believe there is an issue specifically occurring with the Intercom Android SDK, feel free to let us know and we can escalate this to the support team. 👍

Reply