After updating to iOS SDK 12.3.0 my Xcode console stopped working properly and I have seen a lot of new warnings

When I use the console (e.g. to `po` something) in Xcode, now I get

error: expression failed to parse:
error: virtual filesystem overlay file '/Users/distiller/project/DerivedData/archive/Build/Intermediates.noindex/ArchiveIntermediates/IntercomSDK-Dynamic/IntermediateBuildFilesPath/' not found
error: virtual filesystem overlay file '/Users/distiller/project/DerivedData/archive/Build/Intermediates.noindex/ArchiveIntermediates/IntercomSDK-Dynamic/IntermediateBuildFilesPath/' not found
error: couldn't IRGen expression. Please check the above error messages for possible root causes.

I'm not sure what "distiller" is — that is not my username. The implication is that the library is using an absolute path when it shouldn't be.



When I go back to an earlier version of my repo (e.g. by checking out an earlier commit before I upgraded Intercom) the console starts working properly / these Intercom warnings disappear.


I have installed the SDK via Swift Package Manager.


I have tried restarting, clearing Derived Data, resetting the Package cache, and also the steps here , but I still get the same issues.


Best answer by Daniel M15 6 June 2022, 16:54

View original

5 replies

Hey @simon b​ 👋


Would you mind sending us a message through the Messenger with all these details and a Support Engineer can take a look at this for you 🙌

I already did, before I made this post. No answer.

Was able to fix the IRGen issue finally and get `po` to work again by following the steps here again and resetting as much as I could think of without completely removing Xcode etc.


Never mind

The problem has reoccurred after updating to Intercom 12.4.0, so far the steps haven't resolved it.

Userlevel 2

Hey @simon b​! Daniel from Customer Support Engineering here 🔧 


Looks like you were able to get in touch with our team about the issue! If any other users see this and are wondering what your next steps are, I can confirm that our engineering team are currently working to resolve this bug and will hopefully issue a new release very soon. In the meantime, keep your eyes on our iOS GitHub repository for updates 👀