LLDB stopped working after v.15.1.1

Hey folks 👋🏾

After several recent updates, Xcode debugger stopped working for us, 

(lldb) po self

warning: Swift error in scratch context: error: failed to load module 'Pipedrive'


Shared Swift state for Pipedrive has developed fatal errors and is being discarded.

REPL definitions and persistent names/types will be lost.


error: expression failed to parse:

unknown error

Do you have any ideas what can be an issue? We are using cocoapods, but adding framework manually or via SPM doesn’t solve the issue. If we roll back to 15.1.1 everything works fine for us 🤔


Best answer by Brian B11 20 September 2023, 14:55

View original

14 replies

Userlevel 3

Hi there @Andrius Shiaulis !


Are you trying to integrate using Swift Package Manager? If so you’ll want to use as the package URL. You’ll also want to make sure you’re using XCode 14 for your build.

Let me know if you’re still having issues after looking that over!

Hi @Jacob Cox!


A bug was introduced on version 15.1.4 when using carthage to install Intercom as an iOS dependency.


When using versions >= 15.1.4 the lldb command po or e always fails with the error message:

“failed to load module main_module_name”


The same error doesn’t occur on version 15.1.3


Thank you!

Userlevel 3

Hi @Andrius Shiaulis and @kevin from unspun !

The team recently released version 15.2.0 of our iOS SDK. Does that clear up the errors that you’re experiencing?

@Jacob Cox hey, sorry for the delayed reply. We are using cocoapods. 15.2.0 didn’t help unfortunately

@Jacob Cox still not working.

these are the steps I’m following:

  • carthage update --use-xcframeworks --platform iOS intercom-ios
  • import .xcframework on Framewok, Libraries, and Embedded Content
  • put a breakpoint anywhere in the app code
  • run anything using po 

After removing the Intercom framework from the project, or using version 15.1.3 po starts working again


Userlevel 1

@Jacob Cox We’re seeing this on 15.1.5 right now with Swift Package Manager, we did just try 15.2.1 and had the same problems.

From the looks of it there are hardcoded paths in the Library that are breaking things according to “swift-healthcheck” in the Xcode Console: (these look like Circle CI paths, I found them in the Framework file in a few spots)

SwiftASTContextForExpressions::LogConfiguration() -- /Users/distiller/project/DerivedData/archive/Build/Intermediates.noindex/ArchiveIntermediates/IntercomSDK-Public/BuildProductsPath/Release-iphonesimulator
Output from Dwarfdump:
Intercom.framework.dSYM/Contents/Resources/DWARF/Intercom(x86_64):	file format Mach-O 64-bit x86-64
UUID: 1D286629-9F16-3E5E-94F6-B258E4DFC8E0 (x86_64) Intercom.framework.dSYM/Contents/Resources/DWARF/Intercom
DW_AT_LLVM_include_path ("/Users/distiller/project/DerivedData/archive/Build/Intermediates.noindex/ArchiveIntermediates/IntercomSDK-Public/BuildProductsPath/Release-iphonesimulator/Intercom.framework")
DW_AT_LLVM_include_path ("/Users/distiller/project/DerivedData/archive/Build/Intermediates.noindex/ArchiveIntermediates/IntercomSDK-Public/BuildProductsPath/Release-iphonesimulator/Intercom.framework")
0x0006c762: "/Users/distiller/project/DerivedData/archive/Build/Intermediates.noindex/ArchiveIntermediates/IntercomSDK-Public/BuildProductsPath/Release-iphonesimulator/Intercom.framework"
Intercom.framework.dSYM/Contents/Resources/DWARF/Intercom(arm64): file format Mach-O arm64
UUID: 82890EC3-B3EB-341D-81C4-36C5BC761250 (arm64) Intercom.framework.dSYM/Contents/Resources/DWARF/Intercom
DW_AT_LLVM_include_path ("/Users/distiller/project/DerivedData/archive/Build/Intermediates.noindex/ArchiveIntermediates/IntercomSDK-Public/BuildProductsPath/Release-iphonesimulator/Intercom.framework")
DW_AT_LLVM_include_path ("/Users/distiller/project/DerivedData/archive/Build/Intermediates.noindex/ArchiveIntermediates/IntercomSDK-Public/BuildProductsPath/Release-iphonesimulator/Intercom.framework")
0x0006beaa: "/Users/distiller/project/DerivedData/archive/Build/Intermediates.noindex/ArchiveIntermediates/IntercomSDK-Public/BuildProductsPath/Release-iphonesimulator/Intercom.framework"


I’m facing the same issue with the Swift debugger.

My app uses Flutter 3.13.2.

Simply removing the Intercom package makes the debugger work again. Tried with latest intercom version 15.2.1 with SPM from 

This needs urgent fixing as it seriously slows down development on other unrelated parts of the app.

Userlevel 1

We switched to version 15.1.3 and po works again, but we want the latest builds because of crash issues resolved.

Userlevel 1

@Jacob Cox  Can you un-mark this as Solved as it is not solved.

@Engineering if Intercom folks won’t reopen this ticket consider to make a new similar one and we can upvote it to attract some attention to this problem

@Andrius Shiaulis Following your advice I created this new topic : 

This has to get fixed soon ;-) 

Userlevel 3

Hey there!

Sorry for the delayed response here! I just responded to the new thread that @Konstantinos Gaitanis created here. Can you each reach out to the Support team about the issue that you’re experiencing? You can reach out to them via the Intercom Messenger or email ( Thanks!

Userlevel 4

Hey all 👋 


In case you aren’t following along our most recent thread here, the team is looking at this issue with top priority today and we will keep this thread updated as we receive any news!


Really appreciate all of your patience and diligence in flagging this with us. We are actively working out some kinks with our community forum processes to ensure we are notified and able to get replies out faster in these scenarios. Thank for bearing with us as we work on these improvements to offer a better experience for you all next time.

Userlevel 1

Hi everyone 👋

Thanks for your patience while we investigated this issue.

It has been fixed in Release 15.2.3. Please update to this version in order to resolve any debugging issues in Xcode.