Answered

Product Tour showing on other pages

  • 26 September 2023
  • 5 replies
  • 126 views

Userlevel 2
Badge +1

Hi, 

I launched a product tour twice and both times the issues are mostly that it’s appearing on other pages for some users. Is there something I’m missing when setting up the URLs?

I’ve attached screenshots of my URL settings and a screenshot of the issues. The only solution I found is to add all the “does no contain” links to keep it from popping up on those pages. Is there another way around this?

Thank you in advance,

Sulamita

 

icon

Best answer by Jacob Cox 1 October 2023, 19:16

View original

5 replies

Userlevel 5
Badge +4

@Sulamita Ivanov In this case, I don't think you need to use 'contain' because the url is the full url.

 

Do you have the same problem if you make the setting 'is' instead of contains?

 

If you are concerned about tags or other details being added to the end of the url and not showing the tour,  try the 'starts with' option instead. 

 

Technically I don't see why 'contains' shouldn't work as well so maybe there's a bug report needed for 'contains' with urls but I think you should be good with 'is' or 'starting with'. 

 

The only other thing I was wondering is if your app is a single page app and not using the settings for that option but let me know if the above resolves the issue. 

 

Hope this helps! Let us know. 

 

 

 

 

 

 

 

 

 

Userlevel 2
Badge +1

I was recommended to use “contains” because the link has a unique url per user logged in. So if I’m not mistaken, I can use the exact url. 

For example “app.proxyclick.com/CF-AZPV405/emergency-list”

So to make sure it shows up for everyone, I need just the “app.proxyclick.com” and “/emergency-list”. 

Is it correct that “contains” is the only option to make that work?

Userlevel 2
Badge +1

I’ve also selected “does not contain /dashboard” and in the issues it shows that they are on the dashboard page and it can’t find the first step of the tour. When it shouldn’t be coming up on that page at all. 

Userlevel 4
Badge +5

Hi @Sulamita Ivanov !

@Nathan Sudds is correct that you shouldn’t need those ‘does not contain’ rules here. You would just need 2 contains rules for the first part of the URL (before your dynamic variable) and one for the last part of the URL (after that variable).

This will most likely need to be looked at by a member of our Support team so we can investigate the Users that you are showing were on the wrong URL. I’m going to forward this message over to the Support team. They will reach back out to you via the email that you signed up with!

 

Userlevel 2
Badge +1

Sounds good, thank you!

Reply