user_hash looks fine, but intercom is not showing up with a 403 error.

  • 20 April 2023
  • 2 replies


I have embedded the Intercom script using Javascript. When I checked the Intercom setting configuration, everything looked good to me. But when I tried to init Intercom messager, I got an error "Invalid user_hash". Then I tried to check the user_hash value in the setting and compare it to the value in the dashboard. It's all the SAME. Why I still got this error?




Best answer by Daniel M15 24 April 2023, 18:30

View original

2 replies

Userlevel 2

Hey @kohei! Daniel from Customer Support Engineering here 🔧 


It looks like the hash value you’re passing here doesn’t match the one that’s expected from Intercom. I know you mentioned you checked out our hash calculator - can you ensure that you are using the correct token that’s associated with the workspace (your TEST workspace will have a different one) and you have employed the correct hashing algorithm? Let me know if so, and we can escalate this to the Messenger team if need be 👍 

Ive got this exact problem. Im on my test environment, using the correct appId and secret key. The generated hash is identical to the one generated in the Intercom test tool. Still, I get the error “Invalid user_hash”. The answer above is not an answer.