Answered

SSL for custom domain is not working through AWS. I'am getting 502 ERROR The request could not be satisfied.

  • 12 August 2022
  • 3 replies
  • 788 views

We are trying to setup our help center with EU orgin through cloudfront.

 

This is what it returns:

CloudFront wasn't able to connect to the origin. We can't connect to the server for this app or website at this time. There might be too much traffic or a configuration error. Try again later, or contact the app or website owner.

If you provide content to customers through CloudFront, you can find steps to troubleshoot and help prevent this error by reviewing the CloudFront documentation.

 

I have tried everyting following these documentations:

 

 

I have talked to support and I'am only getting redirected to these documentations and not actually solving the problem.

 

My Cloundfront configuration looks like this:

imageimageimageimageEveryting i set correctly in intercom helpcenter settings and at the DNS provider.

This is the error message:

imageCloud it be that the EU orgin: custom.eu.intercom.help does not work with cloudfront distribution?

icon

Best answer by User2403 12 August 2022, 10:46

View original

3 replies

It worked when i set the orgin to: https://custom.intercom-help.eu/however this was not mentioned in any documentation!

Agreed the documentation should be updated with this origin for CloudFront. Thanks for the solution @user2403​ 

@User2403 thanks for this! I would like Intercom to update this. The weird thing was that it did work for us for a couple of hours on the custom.eu.intercom.help origin after getting the same 502 error.

Has your solution worked since then smoothly? It scares me a bit that they have another origin, but it is not mentioned anywhere in their documentation.

Reply