Answered

Setting "Let users start a conversation" to false still alows users to start new conversations

  • 13 December 2023
  • 6 replies
  • 105 views

Badge

We use react native sdk v6.20 and we set “Let users start a conversation” to false to prevent users from starting new conversations. But they still have the button “Send us a message”. 
I read that this should be fixed in v6.20

 

issue seems to be only for users with no conversations. 

if Let users start a conversation is false
user with 0 conversations can see the button to start new conversations in the middle of the screen “Send us a message”
user with 1 conversation doesn’t see the button but only their previous conversations

if Let users start a conversation is true
user with 0 conversations can see the button to start new conversations in the middle of the screen “Send us a message”
user with 1 conversation also sees the button at the top of the modal to start new conversation.

so this means that if you don’t have conversations you can start new conversations regardless of the Let users start a conversation setting
and if you do have conversations then the setting works as expected

icon

Best answer by Larissa Alberti 13 December 2023, 18:14

View original

6 replies

Userlevel 3
Badge +4

Hey @hvalec ziga 👋

Larissa here from Intercom Support.

I’ve tried to reproduce what you mentioned, and I was not able to.

When turning off the feature ‘Let users start a conversation’, I was not able to see the button ‘Send us a message’.

Could you please confirm that you have disabled the feature for both Leads and Users?

 

If so, and you are still able to see the button, we would need to investigate this further.

Please let us know! 

Badge

Yes. I disabled/enabled both visitors and users

Badge

this is when the Let users start a conversation is enabled or disabled, and I have no conversations

this is when Let users start a conversation is off, and i have 1 conversations

this is when Let users start a conversation is on, and i have 1 conversations

 

 

you can see the if I have conversations then the setting works and hides the “Start new conversation” icon at the top right.

if I don’t have conversations then I have button to start new conversation regardless of the setting

Badge

Hi. were you able to reproduce my issues?
If not can you share your screen when you don’t have any conversations and the Let users start a conversation is false?

Badge

Hi. Even after updating to 6.3.0 the issue still persists. Option Let users start a conversation only works if you have some messages where it correctly hides the “start new conversations” icon at the top right. 
If you don’t have any conversations then the “Send us a message” button is always visible
 

Let users start a conversation is off
Let users start a conversation is on

 

 

Button in the middle is always shown

Userlevel 3
Badge +4

Hey @hvalec ziga , Bernice here from the Support Engineering team at Intercom🔧 

I’ve escalated your other post on here to the Support team for further investigation!

Reply