Answered

Unable to send messages via the intercom messenger on Shopify store.

  • 15 July 2021
  • 9 replies
  • 556 views

The messenger application loads and sometimes it doesn't. After loading, if I try send a message it fails and loads back the intercom home screen and is unable to open the past chats.

 

Saw that the POST conversation API is getting a 404 error.

 

Please do help as this is happening in my production shopify store.

icon

Best answer by Roy 20 July 2021, 00:51

View original

9 replies

Userlevel 1

Hey @user718​, how did you install the Messenger initially on your Shopify store? Did you use our official Shopify integration?

Hi @eric f11​ 

 

I installed using the intercom app store.

 

Shopify website installation process

Intercom> Appstore> Shopify app> install button> provided my store url> authorize access.

Added condition in

Intercom> Messenger Settings> Control your inbound conversation volume> show messenger launcher to all visitors and users.

 

It was working 2 days ago and I have done no changes but it just stopped working.

 

Today observed one more issue:

We have implemented intercom SDK to our mobile app. ON messenger launcher the apps are not loading.

 

This is causing serious problems for our account, , so is there any way to get in touch with anyone via call.

 

Screenshot of error in the website

Screenshot 2021-07-16 at 9.04.54 PM 

 

Screenshot on website messenger launcher apps not loading

Screenshot 2021-07-16 at 8.55.55 PM 

Screenshot of messenger launcher apps not loading:

Screenshot 2021-07-16 at 8.59.51 PM 

Userlevel 1

Thanks for sharing those screenshots @user718​, they're very helpful for extra context. We don't offer phone support of any kind, but I'm happy to help you here.

 

With the Shopify issue, do you encounter the same issue in an incognito window/private browser? I want to rule out any browser extensions which may be causing this issue.

 

On the mobile apps issue, I'd recommend contacting our Support team directly about this via the Messenger, as it looks to be specific to your configuration.

Userlevel 1
Badge

Hello @user718​ ,

 

Upon checking, appears there are some 401 errors coming from Cloudflare. I'm suggesting checking Cloudflare integration, disable any firewalls or page rules (If there are any), and recheck.

 

Let me know if that works okay?

Hi @eric f11​ ,

 

  1. No I am not running any browser extension firewall to block access. I have not setup any trusted domain as well.
  2. I am not running any VPN as well.
  3. I encounter the same issue in incognito and private browsers. Verified in multiple countries and browser ( chrome, firefox, safari)

 

Hi @roy s11​ ,

 

Thank you for the message, but there aren't any firewalls and allowed access to all.

Userlevel 1
Badge

Hi @user718​ ,

 

Thanks for your reply, I just checked the developer console errors that your website is getting:

Failed to load resource: the server responded with a status of 401 () - /apps/intercom-proxy:1

 

Let's troubleshoot this

Can you just disable the Intercom app and install the Intercom code manually?

 

1. Disable Intercom App;

2. Find Intercom code for logged-in visitors. Settings -> Installation -> Web -> Install chat for visitors -> With Code.

 

Then click on the Copy Code button

3. Go to Shopify Admin -> Online Store > Themes

4. Click on Actions > Edit code

5. Find theme.liquid file and paste the Intercom code just above the closing </body> tag.

 

Then save and check if Intercom messenger appears on your website.

 

Looking forward.

Hi @roy s11​ ,

 

I have tried with the script tag inclusion in shopify theme but still its not working. Its throwing same error. 

 

We have two apps or environments for intercom. The issue we are facing is for production app only. But when we pointed testing intercom app to our production website then it worked, which means no issue with firewall. Something wrong with production intercom app whereas we haven't changed anything.  Could you please provide any pointers around this ?

 

I have the same problem. Just randomly the messenger stopped working and returns a 401 error on app/intercom-proxy. Any solutions other than trying to install code manually?

Reply