Answered

Umbrella Header issue in iOS SDK 12.3.0

  • 20 May 2022
  • 6 replies
  • 115 views

I recently tried upgrading from 11.1.0 to 12.3.0 of the Intercom iOS SDK and encountered the following error when attempting to build and archive:

umbrella header for module 'Intercom' does not include header 'ICMLoadingViewController.h'

I am using the following:

  • macOS 12.4
  • Xcode 13.4 (13F17a)
  • Swift Package Manager (swift-tools-version:5.6)
  • Fastlane 2.206.0
  • Minimum iOS target version of 13.0

 

I also had the same issue when attempting to use version 12.2.1 of the Intercom iOS SDK.

 

Has anyone else encountered this or found a workaround?

icon

Best answer by Mikhail K 24 June 2022, 13:50

View original

6 replies

Hey @ryan z​ 👋

 

Would you mind sending us a message through the Messenger with these details so that a Support Engineer can look into this for you please? 🙌

Hey @ryan z​!

 

I actually ran into this a bit while updating my own environment. This can happen due to old build files causing issues when upgrading your SDK. Could you try each of these, and in-between attempt a new build?

 

  1. Cleaning your build folder. In XCode, it'll be under Product >> Clean Build Folder (Or shift + cmd + K). Try to build again.
  2. Manually importing the missing header? You can add: "#import 'Intercom/ICMLoadingViewController.h'". Try to build again.
  3. Delete the "DerivedData" folder, and try building again. There's a small guide on how to do that here. After doing this, restart xcode and try to build again.

 

Please let me know if either of these worked, and if so, which one! 🙏🏻

 

 

 

Hey @ryan z​ 

May I ask you, have you found a solution? We faced the same problem and we decided to revert version back to 11.1.0. All environment is exactly the same as yours.

Just want to note that it is not a single warning. When we use 12.4.1 version it adds 71 warnings to the project ('ICMLoadingViewController.h', 'ICMMetric.h', 'ICMAvatarView.h' and others)

 

I really hope somebody from Intercom works on this issue🤞🏼

No I haven’t had time to circle back, so for the time being I am just staying on 11.1.0. And yes, it’s not a single warning but dozens for me as well.

The issue has been fixed in 12.4.3. I've checked and can confirm all warnings is gone 🎉

That's great to hear, thanks for the update!

Reply